対象製品:365 Alert Outlook Add-in
作成日付:2026/06/11
質問:
リンク共有(SharePoint)時に以下のエラーでメール送信できなくなりました。
「フォルダの共有に失敗しました Status Code [403]」
外部宛先を含む場合に発生するようですが、先日までは同じ外部宛先に送信しても問題なくリンク共有ができていました。
考えられる原因と対処方法を教えてください。
回答:
原因:
2026/5時点、Microsoft社ではOneDrive / SharePointにおける外部共有方式を、ワンタイムパスコード(OTP)方式からB2B方式へ段階的に移行しています。
これに伴い、B2B方式が有効なテナントで365 Alert Outlook Add-inのリンク共有(SharePoint)機能において必要な操作(後述の「アクセス許可付与」)を2026/5/26以降に未実施の場合、外部共有に失敗する事象が発生します。
対処方法:
管理者様側で以下の手順を参考に「アクセス許可付与」を実施してください。
<「アクセス許可付与」手順>
1.「365 Alert OAI Admin」アイコンをクリックして、アドインの設定メニューを開いてください。
2.「アクセス許可」の「Outlook Add-inに管理者の同意を付与」をクリックして、 Microsoft 365テナントの管理者権限のあるアカウントでアクセス許可を承諾してください。
参考)アクセス許可付与
https://docs-alert-oai-admin.wise365cloud.com/outlook_add_in/settings_menu#%E3%82%A2%E3%82%AF%E3%82%BB%E3%82%B9%E8%A8%B1%E5%8F%AF%E4%BB%98%E4%B8%8E
なお、B2B方式に移行前と考えられる環境であっても上記手順を実施して問題ありません。
365 Alert Outlook Add-inの他機能に影響はありません。
補足:
・B2B統合が有効な環境で、外部宛先に対してリンク共有を行うと対象の外部ユーザはゲストアカウントとして登録されますが、これは弊社製品を利用せずにファイル共有を行った場合でも同様であり、2026年3月時点のMicrosoft社の仕様となります。
・OTP→B2B に移行することで、これまで外部ユーザーがアクセス時に発生していたワンタイムパスコードによる認証は、原則として発生しなくなります。 受信したアカウントが Microsoft アカウントである場合は Microsoft サインイン、そうでない場合は E-mail OTP 認証によりアクセスが行われます。 なお、Microsoft アカウントでない場合であっても、Microsoft サインイン画面が表示される場合がありますが、仕様によるものです。受信したメールアドレスを入力のうえ、画面の案内に沿って進めていただくことでアクセスが可能です。