対象製品:WISE Alert
バージョン:共通
作成日付:2026/06/09
質問:
リンク共有(SharePoint/OneDrive)時に以下のエラーでメール送信できなくなりました。
「フォルダの共有に失敗しました。Status Code 400」
外部宛先を含む場合に発生するようですが、先日までは同じ外部宛先に送信しても問題なくリンク共有ができていました。
考えられる原因と対処方法を教えてください。
回答:
原因:
2026/5時点、Microsoft社ではOneDrive / SharePointにおける外部共有方式を、ワンタイムパスコード(OTP)方式からB2B方式へ段階的に移行しています。
これに伴い、B2B方式が有効なテナントでWISE Alertのリンク共有( OneDrive / SharePoint)機能において必要な操作(後述の「管理者の同意」)を2026/3/31以降に未実施の場合、外部共有に失敗する事象が発生します。
対処方法:
以下の手順を実施してください。
<「管理者の同意」手順>
1.https://entra.microsoft.com/ にMicrosoft Entra 管理者でサインイン。
2.エンタープライズ アプリケーション を開く。
3.リンク共有(OneDrive)の場合は「WISEAlert.OneDriveApp」を選択。
リンク共有(SharePoint)の場合は「WISEAlert.SharePointApp」を選択。
4.アクセス許可 → “tenant名 に管理者の同意を与えます” をクリック
5.下記権限が全て表示されていることを確認。
(OneDrive/SharePoint共通で必要)
Files.ReadWrite.All
offline_access
openid
User.Read
User.Invite.All
(SharePointのみ必要)
Sites.Read.All
なお、B2B方式に移行前と考えられる環境であっても上記手順を実施して問題ありません。
WISE Alertの他機能に影響はありません。
補足:
・本件はWISE Alert の全バージョンで共通して利用しているリンク共有用エンタープライズアプリケーションに関わるため、全WISE Alertバージョンで発生する可能性があります。また、お客様側でのWISE Alertのバージョンアップ作業は発生しません。
・B2B統合が有効な環境で、外部宛先に対してリンク共有を行うと対象の外部ユーザはゲストアカウントとして登録されますが、これは弊社製品を利用せずにファイル共有を行った場合でも同様であり、2026年3月時点のMicrosoft社の仕様となります。
・OTP→B2B に移行することで、これまで外部ユーザーがアクセス時に発生していたワンタイムパスコードによる認証は、原則として発生しなくなります。 受信したアカウントが Microsoft アカウントである場合は Microsoft サインイン、そうでない場合は E-mail OTP 認証によりアクセスが行われます。 なお、Microsoft アカウントをお持ちでない場合であっても、Microsoft サインイン画面が表示される場合がありますが、仕様によるものです。受信したメールアドレスを入力のうえ、画面の案内に沿って進めていただくことでアクセスが可能です。
・本内容は、2026/3/31、2026/6/4にご登録のサポート窓口責任者/担当者様宛にメールで一斉通知のうえ、本サポートセンターサイトの「WISE Alert」コンテンツにも掲載しています(サポート窓口責任者または担当者でサインイン後に表示されます)。