FAQ番号:201906WAL133
製品:WISE Alert
バージョン:共通
作成日付:2019/06/21
質問:
特定の環境で、WISE Alertアドインは無効化されていないのにメール送信時に送信Alert画面が表示されません。
また送信待ち時間なども設定の通りに動作していません。
原因と対処方法を教えてください。
回答:
事象発生日時を含むWISE AlertV3.2以降の調査用ログ(※1)に
・[0x80029c4a]
・[0x8002801d]
上記いずれかの出力がある場合は以下の事例に該当します。対処方法を確認してください。
[事象]
WISE Alertが無効化されていないのに、送信Alert画面がポップアップしない。事象発生時のWISE Alert調査用ログに[0x80029c4a]または[0x8002801d]エラーが出力される。
[原因]
当該環境でオフィスのレジストリに不整合が発生していると考えられます。
[対処方法]
他ユーザー数社で下記の実施により事象解消の報告があります。実施をご検討ください。
- オフィスの修復
- オフィスの再インストール
- レジストリの修正 (手順は本FAQ下部に添付)
[解消しない場合]
根本原因は環境側のレジストリの不整合であり、WISE Alertでは対処できません。
上述のいずれの対処方法でも解消しない場合は、実施済みの対処方法の内容を添えて、以下の内容でマイクロソフト社側へのサポート依頼を検討してください。
----------------------------------------------------------------------------------
OutlookのCOMアドインが読み込まれません。読み込みの際に「 0x80029c4a(または 0x8002801d)タイプ ライブラリ/DLL の読み込みエラーです」のエラーが発生しています。既にXXX(実施済みの対処方法の内容)は実施しましたが解消しません。
----------------------------------------------------------------------------------
また、「Microsoft Access Runtime 2010」のアンインストールを契機に事象が発生し、再びインストールすると事象が解消したとの事例があります。
事象発生時期に、インストール/アンインストールしたアプリケーションがある場合は、そのアプリケーション名もマイクロソフト社側に伝えることをお勧めします。
※1)調査用ログの出力場所は下記です、詳細は使用ガイドを確認してください。
%USERPROFILE%\AppData\Local\WISE Alert
(マニュアル例:C:\Users\[ユーザ名]\AppData\Local\WISE Alert)
なおWISE Alert V3.2以降であれば、デフォルトのログレベル(Verbose=1)で当該エラーが出力されますが、V3.1以前の場合は、いずれのログレ ベルでも[0x80029c4a]または[0x8002801d]エラーは出力されません。調査用ログに当該エラーがあるか確認する場合はWISE AlertをV3.2以降にバージョンアップしてください。